Brackets and the curse of dependencies

So the other day I wanted to install Brackets for front end development. No problems, it’s open source, how hard can it be?

Thought when trying to install from the deb file on my ubuntu 15 I get the error message that there’s no libgcypt11 that are a required dependency.

That’s not strange, it’s deprecated and new systems should use libgcrypt20, that comes with ubuntu 15. But unfortunately the install script still require libgcrypt11 ( >= 1.4.2)

Sure, it’s open source, why not download the source and change the dependency?

Turns out that creating the build script is not that easy. You need to run the grunt tasks, thought “grunt installer” won’t complete unless you do a full build. Guess what, full build won’t complete because the source code require symbols from libgcrypt11.

OK, what about to manually edit the install scripts in the deb file? Unpacking the deb file and changing the control file to libgcrypt11( >= 1.4.2) | libgcrypt20 (>= 1.5.0)

Nope, there’s still a library that don’t work without a call to a crypt function of version 1.2 :(

My advice? If you are going to use a virtual machine anyway, install an older distro, such as Ubuntu 14.

Reading the comments on Brackets they seem to have big problems to create a installer for new Linux distros. For over a year they have not managed to solve this issue. The conclusion is that they don’t really care about Linux so it’s a good idea to use another software. I’ll try Atom.

Another reason I like rolling releases is that you often avoid these dependency problems. Thank you Arch.





Warning: count(): Parameter must be an array or an object that implements Countable in /customers/8/9/4/ on line 399

Leave a Reply

Your email address will not be published. Required fields are marked *